LMLPHP后院

两种父母与他们的孩子

真的系统的构思过吗,真的阅读过吗?这样的长篇大论写起来起码大半天吧,人生有多少个大半天?都不要做其他事情吗?每天花大量的人力用在微信的低质量冗长冗长无意义的扯淡文字里?天下的微信软文大都一个样,写几个奇怪的文字,搭配几张奇怪的图片...渐渐的意识到,一个事物被人们知晓,靠的一定不是质量,除了特权的作用力之外,就是各大媒体和媒介入口的大肆宣传了。在互联网上的文章也是如此,绝大多数高质量的文章反而被湮没了...

Wayland上的Gnome遇到的坑

stom.conf,将 WaylandEnable=false 这一行注释打开。从 GDM 3.16 版本起,默认情况下使用 Wayland 后端。在 Wayland 上运行的 Gnome 会出现很多奇怪的问题,让人一下子找不出原因。我很喜欢的终端 Tilda,在这种情况下,就不能启动了,会报很多奇怪的错误日志,大意是不能连接到 Dbus,如下日志片段:[xcb] Unknown sequence n...

从百度、360、搜狗对新站态度看国内搜索引擎技术现状

,上线不久后我添加了网站统计的代码。最先加入的是百度统计,然后站长统计,然后Google-Analytics,最后加了51啦统计。加入代码后,我一直关注网站被收录数量,也尝试提交了Sitemap。但是奇怪的是,国内的搜索引擎都只收录首页,并且更新的特别慢。刚开始,我并没有加入Google的代码,但是Google却将网站的链接全部都收录了,这个可能跟网站的服务器在Provo有关,纵然如此,对谷歌那个崇拜...

PHP简写三目运算符实现二选一

使用三目运算符简写的方式实现二选一,如下示例: $name = $obj->name ?: 'Anonymous'; 好的程序员应该写出好的代码,好的代码就应该选择一种最好的方式来写,而不是去写一些很奇怪的东西,这样容易造成别人的误解,特别是团队开发。 比如,在 PHP 中,我们一般习惯用 isset() 来判断是否有设置值,但有些人会使用 @ 符号来屏蔽报错,其实这样是不规范的,屏蔽 Notice ...

安装安全补丁KB958644解决WinXP下不能访问exFAT文件格式

ls.aspx?id=3205,Security Update for Windows XP (KB958644)。安装完成后重启系统即可,插入 USB 3.0 之后,发现可以识别新的移动硬盘了,不过奇怪的是,上面显示的属性依然是 NTFS 文件格式。exFAT 文件格式本身就是介于 FAT32 和 NTFS 之间的一个文件格式,也许是这个缘故吧?。...

Win7升级Win10后分辨率太低只有1024*768怎么办

机了,直接崩溃。到底怎么回事,是不是 Win10 的 defender 惹的祸呢?最后只能从 U 盘启动,备份数据,有空再折腾下,或者重装系统。吐槽下,微软的很多设计真的很不符合中国人的习惯,不说一些奇怪的中文目录,就连编码就很让人讨厌,在 Linux 下挂载直接乱码。写这么多旨在告诉世人,千万别折腾系统,多留些寿命精力。千万别对新的系统软件抱有好的态度或想法,一定会被坑的,千万别玩 Win10。最后...

花生WIFI天猫百度图片加载失败问题

在上海挤地铁上班的人应该会经常连接花生WIFI,也许会发现一个问题,有些网站的图片加载不了,比如天猫,百度,一点资讯什么的。这个问题我一开始也觉得很奇怪,时间一长,就想了解到底是什么原因。我开始求证,在电脑上调试天猫移动站点的图片,发现百度和天猫的图片在移动 UA 下使用的是 webp 后缀文件名,天猫的图片文件名里面含有感叹号逗号等一些非常规字符。webp 是谷歌研发的有损图片压缩格式,率先在 ch...

如何让MySQL支持utf8mb4字符集

O CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;遇到的问题,在 Ubuntu 下操作请不要使用 service 的方式重启 MySQL,这样会导致奇怪的错误,比如无法启动等,直接在 /etc/init.d/ 下面重启。关于网页支持 utf8mb4 问题。在使用 PDO 操作的时候,如果提交了 emoji 表情到数据库,并且数据库不支持 emoji ...

2016即将逝去展望拥抱2017

到千分之一,每次点击收入几毛钱。而一个微信公众号让用户主动掏钱,每次单价最少一元人民币吧,确达到了百分之一的比例,这样的数字不知道谷歌的创始人和李彦宏看到了会不会眼红。微信的成功,正常人也能理解,并不奇怪。腾讯用户基数大,微信自然的将用户从 QQ 转过来了,一些年纪大一点的人直接从诺基亚时代换上移动互联网新装备进入微信。所以,我一直认为,微信更多的是为了吸引一些年纪大的人进入移动互联网,对于年轻的 8...

解决configure: error: Cannot find OpenSSL's <evp.h>

ql 扩展,官方推荐使用 mysqli 和 pdo_mysql。在使用源代码安装 PHP 时,默认是不会安装 pdo_mysql 扩展的,这样动态编译 mysqlnd、pdo_mysql 扩展会报一些奇怪的错误,如下:configure: error: Cannot find OpenSSL's <evp.h> 尝试了很多方法,依然解决不了这个问题,其实 evp.h 是存在的,于是只能重新编译 PHP...
2019-11-20 05:08:26 1574197706 0.040278