LMLPHP后院

Chrome插件在高版本浏览器中安装报错解决

o 2 (without quotes). See developer.chrome.com/extensions/manifestVersion.html for details. 上面的错误系插件版本过低,在高版本Chrome中需要在manifest文件中添加 manifest_version 配置项。 按照上面的提示在清单文件中增加了 "manifest_version": 2 配置项,又出现如...

GITHUB之GIT BASH使用教程

一,可以免费的托管开源代码。作为一名软件工程师,对代码的管理养成一个良好的习惯是非常重要的。本人将讲解如何使用 GIT BASH 管理 GITHUB 中的代码库。Git 是基于 Linux 内核开发的版本控制工具。与常用的版本控制工具 CVS,Subversion 等不同,它采用了分布式版本库的方式,不必服务器端软件支持,使源代码的发布和交流极其方便。 Git 的速度很快,这对于诸如 Linux ke...

PHP扩展exif源代码编译安装教程

这样做过了。但 exif 扩展比较重要,在某些发行版比如 ArchLinux 上并不默认安装这个扩展,所以需要在 PHP 官方网站下载原始代码编译安装。所有的技术产品网站都有一个通病,就是很难找到历史版本在哪里下载。PHP 在下载页面暴露出来的下载链接,点进去依然只有几个版本的下载,由于我使用的 PHP 版本是 php-7.0.9,所以必须找到对应的版本来安装扩展。在 mirror 页面找到一个版本后...

Jquery绑定Ajax请求全局错误处理不生效的问题

请求错误处理的,如果每个请求发生错误都单独处理,那是非常可怕的, 设计全局错误处理是非常重要的。 看 JQ 的官方文档,提供了 ajaxError 的错误处理方法,该方法在 Jquery 比较新的后续版本中只支持绑定在 document 上了。看官方文档给人的感觉是,你只能使用 ajax 才能有效,什么 get,post, getJson, getScript 等都不一定会生效,如果想不被全局错误处理...

Windows下修复VirtualBox不能为虚拟电脑打开一个新的任务

rchLinux 都没有出过什么问题,前段时间在 Win7 上安装,就出了一个"不能为虚拟电脑打开一个新的任务"的报错,折腾了好久没有搞定,最终的解决办法就是回退到 VirtualBox 4.3.0 版本,解决问题。关于"不能为虚拟电脑打开一个新的任务"这个问题的解决,网上找了很多,各大搜索引擎都找了,中文的,英文的网页,最终没能解决问题,无意中看到有个人说回到以前的版本,就解决了。网上提供的方法都试...

使用array_map取代PHP函数array_column

PHP 函数 array_column 是 PHP5.5 之后才支持的,在国内各大平台运行环境比较混乱的情况下,绝大多数的主机服务器还都在使用 PHP5.3 左右的版本。为了程序的健壮性,慎用此函数,最好使用 array_map 来取代它,不过 array_map 的取代也只能向下兼容到 5.3 的版本,因为需要使用 lambda 函数表达式。如下示例:array_column($array, $co...

一颗巨星的陨落 CodeWeBlog

nux基础,english,CookbookForSymfony2,mysql数据库,unity3d,Java2实用教程笔记,Python相关,布局与层,机器学习,注册码,object-c,组网教程,版本控制,tips,dataanalysistheory,vb,photoshop,存储过程,spark,Linux服务相关,数据结构&算法,学习心得,缓存-Redis,linux/lubuntu,代码,...

开源框架LMLPHP-monkey发布强力回归WEB开发本质

很少有人知道 LMLPHP 框架还有一个版本,monkey 版本。其实早该出来的,只是一直没有时间来做这件事情。这回终于可以装一回逼了,LMLPHP-monkey 需要 PHP 5.3 以上版本,让那些喜欢 namespace 的人可以高大上一回。GITHUB 地址 https://github.com/leiminglin/LMLPHP-monkey LMLPHP-monkey 让开发回归本质,不...

LMLPHP第五期更新功能

控制器类中配置conditions属性快速便捷的实现方法执行时的条件方法,当指定的条件方法返回“真”时才会执行该方法,此功能极大的方便了开发中的权限控制,并降低了代码的冗余。由于系统需要支持PHP的低版本,目前条件属性和条件方法的属性必须为public才能正常工作,当后期不再支持低版本时就没有这种要求。上期回顾 http://mp.weixin.qq.com/s?__biz=MzA3MDk5MTUyN...

如何在Windows下安装PHP7及Composer

runtime 的架构选择不一致,会出现 vcruntime140.dll 找不到的错误。对应的选择 VC14 x64 Non Thread Safe (2016-Dec-02 07:19:37) 版本。刚开始眼花了,下载 PHP 的时候选择了 X86 的地址 http://windows.php.net/downloads/releases/php-7.1.0-Win32-VC14-x86.zip...
2020-04-02 19:49:18 1585828158 0.071444